Actualizando el NetworkManager.

Publicado originalmente por zhorro Ver mensaje
Para los que tengan como yo en el trabajo la Wifi con WPA Enterprise (necesita usuario y clave para la conexión y opcionalmente un certificado), no vale la versión del NetworkManager del ACER por que solo soporta WPA Personal, hay que actualizarla a una versión superior, he estado buscando y en aspireoneuser ya habían encontrado que versiones andaban bien con el ACER, lo he instalado en el ACER y no he tenido efectos colaterales en la instalación, a mi wifi de casa (WPA personal) solo le he tenido que volver a dar la clave y ha funcionado correctamente. Recordaros que al actualizar es bastante posible que no os funcionen las actualizaciones de ACER del NetworkManager.

Como cambios importantes es que categoriza las conexiones en 4 pestañas, una para cableado, otra para inalambrico, otra para banda ancha móvil (3G o GPRS), VPN y DSL (PPPOE). Que en seguridad inalambrica tienes el WPA/WPA2 Enterprise y un wizard para configurar las VPN.

Las instrucciones de instalación os las anexo:

se abre un terminal (Alt-F2 Terminal) y se ejecutan los siguientes comandos:

Nos creamos un directorio donde descargar la aplicación

mkdir /home/user/Downloads/rpm

Nos ubicamos en ese directorio.

cd /home/user/Downloads/rpm

Nos bajamos la aplicación de los repositorios, es importante bajárselos antes por que la desinstalación de NetworkManager desconecta la red.

wget ftp://fr.rpmfind.net/linux/fedora/re…7.fc8.i386.rpm
wget ftp://fr.rpmfind.net/linux/fedora/re…0.fc8.i386.rpm
wget ftp://fr.rpmfind.net/linux/fedora/up…5.fc8.i386.rpm
wget ftp://fr.rpmfind.net/linux/fedora/up…5.fc8.i386.rpm
wget ftp://fr.rpmfind.net/linux/fedora/re…5.fc8.i386.rpm
wget ftp://fr2.rpmfind.net/linux/fedora/u…5.fc8.i386.rpm

Desinstalamos la versión actual de NetworkManager del ACER

sudo rpm -e –nodeps NetworkManager
sudo rpm -e –nodeps NetworkManager-gnome
sudo rpm -e –nodeps NetworkManager-glib

El comando que sigue, si tienes la versión actual del NetworManager te deberia decir que no puede desinstalarlo, o sea que si da ese error no te preocupes.

sudo rpm -e –nodeps krb5-auth-dialog 

Ahora instalamos los paquetes con la nueva versión del NetworkManager

sudo rpm -ivh –nodeps NetworkManager-0.7.0-0.6.9.svn3675.fc8.i386.rpm
sudo rpm -ivh –nodeps NetworkManager-gnome-0.7.0-0.6.9.svn3675.fc8.i386.rpm
sudo rpm -ivh –nodeps NetworkManager-glib-0.7.0-0.6.9.svn3675.fc8.i386.rpm
sudo rpm -ivh –nodeps krb5-auth-dialog-0.7-5.fc8.i386.rpm

Estos dos ultimos son para la gestión de redes privadas virtuales el vpnc es compatible con Cisco y la Openvpn es una pues compatible con openvpn , yo no los he instalado por que la de mi trabajo no es compatible con ninguna de las dos y todo me funciona correctamente, por lo que podeis considerar la instalación de estos dos paquetes como opcional.

sudo rpm -ivh –nodeps NetworkManager-openvpn-0.7.0-2.svn3047.fc8.i386.rpm
sudo rpm -ivh –nodeps NetworkManager-vpnc-0.7.0-0.4.svn3030.fc8.i386.rpm

Despues de haber instalado todos los paquetes reinicias el portatil y cuando arranques si tenias una conexión wifi antes te volvera a pedir la clave.

Y si teneis una red WPA/WPA2 Enterprise pues en mi caso sería

Seguridad: WPA y WPA2 Enterprise
Autenticación: EAP protegido (PEAP)
Certificado: el de mi empresa
Autenticacion MSCHAPv2
Nombre de usuario y contraseña los que te hayan dado.

El certificado puede ser que no lo tengas en tu empresa y solo utilices usuario y password, depende del nivel de seguridad que quieran establecer.

¿tienes una sugerencia o duda? - Preguntanos !!